Feb
14
2010
7

How to setup automatic Polycom provisioning for the Asterisk 2.0 GUI

Recently we covered the installation of Asterisk 1.6 + Asterisk GUI 2.0.  In this article we will talk about the details necessary to enable Polycom provisioning from the ‘Users’ tab of the Asterisk 2.0 GUI.  By default auto-provisioning will not work out of the box.  You would think when the GUI is installed that it would be setup as well, considering that you have the option to enter a MAC address in the user extension creation process.

Nor are their docs related to configuring this in the source packages(that I could find).  Online forums and tutorials were of no help either.  There are many post online claiming that you need to set up DHCP, ‘option 66’ for Polycom provisioning to work.  This is true of TFTP provisioning from AA50 appliance, but not from the Asterisk 2.0 GUI that relies solely on HTTP.  At least as far as I can tell.

I think Digium is being vague on purpose about this because they do not want to undermine their Asterisk Appliance product.  While I understand this line of thinking, it’s not consistent with the Open Source business models that have succeeded.

Open Source depends on reaching vast amounts of people due to the low cost.  When my customers have to choose between a Avaya system(running Linux) that cost $45,000 /w phones or a Asterisk system w/ Polycom phones for $19,000; it makes the lesser known Asterisk product attractive.  Over time the base builds up and Digium collects on hardware and support fee’s.

So from my perspective, any Asterisk installation helps Digium’s bottom line eventually.  Even if Digium doesn’t see money from every Asterisk user, simply the presence of those users makes Asterisk a more credible product.  Bringing more and more Enterprise and Government contracts to everyone, thus more money and investment into Digium.

Alright my tirade is over, back to business!  This post assumes you have installed a recent version of Linux, Asterisk 1.6 and the Asterisk 2.0 GUI installed.  If you do not, read my post:How to setup the Asterisk 2.0 GUI with Asterisk 1.6.

The Goals of this Post:

-configure phoneprov for Asterisk 2.0 GUI

(more…)

Feb
11
2010
39

How to setup the Asterisk 2.0 GUI with Asterisk 1.6

Recent versions of Asterisk 1.6 are compatible with the Asterisk 2.0 GUI.  This wasn’t always the case, as the Asterisk GUI was developed for the 1.4 branch.  Although I wish Digium had gone for the LAMP model, the GUI is pretty good and getting better all the time.  However the instructions to install are difficult to find on the asterisk.org website.  That is, if they are there at all.  My guess is that Digium doesn’t want to make it to easy to get a free GUI.  I think this a very poor strategy, but that’s another article….  Today we will run through a quick install of asterisk and the 2.0 GUI.  A far superior option as compared to to Trixbox and FreePBX.

GOALS OF THIS POST:
– Install Asterisk 1.6
– Install Asterisk 2.0 GUI

(more…)