Feb
28
2009

UPDATE: Using Multiple interfaces with KVM and Xen

I had a system crash with blinking keyboard lights. The error has something to do with either ACPI power states or the bridge interface. On my system setting br1 to DHCP causes some kind of issue when using DHCP, here is my log:

Feb 26 03:25:29 mattcom1 dhclient: DHCPREQUEST on br1 to 255.255.255.255 port 67
Feb 26 03:25:29 mattcom1 ntpd[2188]: Listening on interface #22 eth0_rename, 192.168.1.254#123 Enabled
Feb 26 03:25:29 mattcom1 avahi-daemon[2374]: Registering new address record for fe80::20a:5eff:fe45:7eca on eth1.*.
Feb 26 03:25:30 mattcom1 avahi-daemon[2374]: Registering new address record for fe80::20a:5eff:fe45:7eca on br1.*.
Feb 26 03:25:31 mattcom1 ntpd[2188]: Listening on interface #23 br1, fe80::20a:5eff:fe45:7eca#123 Enabled
Feb 26 03:25:32 mattcom1 dhclient: DHCPREQUEST on br1 to 255.255.255.255 port 67
Feb 26 03:25:32 mattcom1 kernel: ————[ cut here ]————
Feb 26 03:25:32 mattcom1 kernel: WARNING: at net/core/dev.c:1505 skb_gso_segment+0×6e/0×153() (Tainted: P )
Feb 26 03:25:32 mattcom1 kernel: Hardware name:
Feb 26 03:25:32 mattcom1 kernel: Modules linked in: sit tunnel4 udf fuse bridge stp bnep sco l2cap bluetooth sunrpc ipv6 cpufreq_ondemand acpi
_cpufreq dm_multipath kvm_intel kvm uinput snd_ens1371 gameport snd_rawmidi snd_ac97_codec ac97_bus nvidia(P) snd_seq_dummy snd_seq_oss snd_se
q_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd iTCO_wdt e1000e iTCO_vendor_support soundcore ppdev 3c59x
firewire_ohci snd_page_alloc firewire_core i2c_i801 parport_pc mii floppy parport i2c_core pcspkr crc_itu_t ata_generic pata_acpi sha256_gener
ic cbc aes_i586 aes_generic dm_crypt crypto_blkcipher [last unloaded: microcode]

then later…

Feb 26 03:52:06 mattcom1 kernel: qemu-kvm[10261]: segfault at 1df ip 080afcb8 sp bfed6898 error 4 in qemu-kvm[8047000+175000]
Feb 26 03:52:06 mattcom1 avahi-daemon[2374]: Withdrawing address record for fe80::3c3b:13ff:fedb:cfcb on vnet0.
Feb 26 03:52:06 mattcom1 kernel: br1: port 2(vnet0) entering disabled state
Feb 26 03:52:06 mattcom1 kernel: device vnet0 left promiscuous mode
Feb 26 03:52:06 mattcom1 kernel: br1: port 2(vnet0) entering disabled state
Feb 26 03:52:07 mattcom1 ntpd[2188]: Deleting interface #27 vnet0, fe80::3c3b:13ff:fedb:cfcb#123, interface stats: received=0, sent=0, dropped
=0, active_time=1289 secs

So I set br1 to a static IP and seems to work, though since it is a bridge I don’t see why it needs an IP address anyways… so turn it off by editing the bridge and the real interface to have no IP.

-Matt

/etc/sysconfig/network-scripts/ifcfg-br:

DEVICE=br1
TYPE=Bridge
ONBOOT=yes
BOOTPROTO=static
NM_CONTROLLED=no





No Comments »

RSS feed for comments on this post. TrackBack URL

Leave a comment