Jul
20
2009
3

ATI HD 4870 (catalyst 9.6) fails to load World of Warcraft

I just upgraded to a ATI HD 4870(w/ 1 Gig DDR 5!).  I read some rave reviews about the 4800 series cards and heard via the grapevine that ATI had much improved Linux support.  However, I was disappointed to find out that the catalyst 9.6 driver will not build with Fedora 11’s stock 2.6.29 kernel.  Bummer, I really like Fedora 11.

So I downgraded to Fedora 10 and the ATI driver built without problem.  My next mission was to install WoW, which went fine.  I was able to download and install without error.  But when I start the game I get one of two typical errors:

====================================================
[matt@localhost World of Warcraft]$ wine Wow.exe
err:alsa:ALSA_CheckSetVolume Could not find ‘PCM Playback Volume’ element
fixme:mixer:ALSA_MixerInit No master control found on HDA ATI HDMI, disabling mixer
fixme:mixer:ALSA_MixerInit No master control found on Brooktree Bt878, disabling mixer
fixme:advapi:SetSecurityInfo stub
archive Data\enUS\patch-enUS.MPQ opened
archive Data\patch.MPQ opened
archive Data\enUS\patch-enUS-2.MPQ opened
archive Data\patch-2.MPQ opened
archive Data\expansion.MPQ opened
archive Data\lichking.MPQ opened
archive Data\common.MPQ opened
archive Data\common-2.MPQ opened
archive Data\enUS\locale-enUS.MPQ opened
archive Data\enUS\speech-enUS.MPQ opened
archive Data\enUS\expansion-locale-enUS.MPQ opened
archive Data\enUS\lichking-locale-enUS.MPQ opened
archive Data\enUS\expansion-speech-enUS.MPQ opened
archive Data\enUS\lichking-speech-enUS.MPQ opened
fixme:win:EnumDisplayDevicesW ((null),0,0x39edac,0x00000000), stub!
^Cwine: Unhandled page fault on read access to 0x00000018 at address 0x624dbf3e (thread 0009), starting debugger…
============================================================

(more…)